Dear DAVID Community,

As you are probably aware, the entire DAVID company, team and product range has been integrated into HP Inc.
This forum is now read-only. Relevant content has been migrated to HP and merged into HP's Support Forums on November 1, 2016.

To start new discussions for 3D Scanning, please register and post your new topic at the HP Support Forums

[Solved] Cleaning tool cuts geometry but doesn't cut texture

If you found a bug, please post it here and we will try to eleminate it as soon as possible.

[Solved] Cleaning tool cuts geometry but doesn't cut texture

Postby Artisan S » Sun Apr 13, 2014 6:21 pm

David v3.10.0 finding:

Laser kit (615 webcam), i5, 8Gb, AMD video card....

I wanted to ad a uniform bottom on a not so uniform jug (see screenshots) and while trying to do so I made extensive use of the cleaning tool in order to cut all parts of the geometry that where of no use to me since I only needed a loose bottom (oops that sounds kinda funny :-)). Here is what I mean......in principle it does not matter how I attach the bottom to the rest of the scan (old wine jug by the way out of my personal collection of strange memorabilia), so I scanned 4 scans of the bottom, duplicated one, alligned all 5 scans untill I had enough geometry to let the hole filling algoritm of the Shapfusion tool take over (it is great so why not use it). Now the result was somewhat supprising since the whole filling/fusing algorithm kept on playing with a texture that should not be attached to any geometry.....compare first file (the lose and edited scans) with the fusion and you see flowers where they shouldn't belong.

To reproduce:

Make scan 1, texture the scan, make scan 2, texture the scan, align by hand (slightly misaline for demonstration purposes), cut part of scan 1, fuse....cut part of scan 1 will not infuence geometry but it will still influence the texture.

Greets, Ed.
Artisan S
 
Posts: 26
Joined: Fri Mar 14, 2014 12:26 pm

Re: Cleaning tool cuts geometry but does not cut texture

Postby Sven » Tue Apr 15, 2014 6:30 pm

Hi Ed,

Thanks for your report.
I can't see your images, but I guess I know what you mean. It's not a bug, it's a feature! ;-)

Filling holes is meant for small holes at places that could not be scanned (maybe too dark, or no light from projector / laser could reach that point). However the texture is always a full camera image with no holes. During Fusion, when DAVID computes that a camera must have seen the surface patch, it will use the texture from that camera.

By the way, you can edit the textures of single scans by opening the .PNG files with image software like Paint, Photoshop, Gimp...

Maybe you can post the pictures, then we can see what the problem is...

Thanks
Sven
User avatar
Sven
DAVID Developer
 
Posts: 1541
Joined: Mon Jan 22, 2007 8:59 am
Location: Braunschweig, Germany

Re: Cleaning tool cuts geometry but does not cut texture

Postby Artisan S » Sat Apr 19, 2014 6:54 am

Hmzz, let me try again.

Yeps, Swen I understand it is a (verry, verry usefull) feature, but sometime I'm a bit naughty and do not observe to many rules......in this case I laserscanned the bottom part of the winejug (no I did not empty it first :-)) in 4 steps and figured that the whole closing algoritm would forgive me if these weren't perfectly aligned with the rest. Well, it sort did not (as the second image shows).

But since then I invested in a 89 euro PicoPix 1230 and I'm happyly using the motorized turning table of mr. VirtuMake......(insert elegant bow, it is great) and that makes scanning a lot more confortable....more confort = more scans = less problems....

However it would be nice if you could control the way David uses it's textures.....but that I admit is not a bug report but a feature request.......case closed.

And yes you can edit the texture files in Gimp.....and even using the texture paint feature of Blender (if you PC is up to the job), so no harm done (btw, try that with a Mephisto CX Pro texture file :-)).

Greets, Ed.
Attachments
2014-04-13_19-10-54.png
Before and.....
2014-04-13_19-12-05.png
after fusion.....
Artisan S
 
Posts: 26
Joined: Fri Mar 14, 2014 12:26 pm


Return to Bug Report

Who is online

Users browsing this forum: No registered users and 2 guests