[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4807: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3904)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4809: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3904)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4810: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3904)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4811: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3904)
DAVID-Laserscanner Forum • View topic - [HelpNeeded] Bug in the new version 3.9.0.4072 64 bits
Dear DAVID Community,

As you are probably aware, the entire DAVID company, team and product range has been integrated into HP Inc.
This forum is now read-only. Relevant content has been migrated to HP and merged into HP's Support Forums on November 1, 2016.

To start new discussions for 3D Scanning, please register and post your new topic at the HP Support Forums

[HelpNeeded] Bug in the new version 3.9.0.4072 64 bits

If you found a bug, please post it here and we will try to eleminate it as soon as possible.

Re: Bug in the new version 3.9.0.4072 64 bits

Postby BobGarrish » Sun Oct 20, 2013 5:02 am

Another one: David generates patterns at the resolution of your main monitor, which might not be the same as your projector. This means that it only shows part of the pattern on the projector. In my case, it only showed the cross in the center plus three squares left and right when the whole image has six squares left and right.

I fixed this by changing my main screen resolution to the same res as the projector, but it still fails to calibrate. The live view at least shows the actual camera view (instead of an almost black image) now if I take my hand away really fast right when it changes from camera to projector calibration.
BobGarrish
 
Posts: 8
Joined: Mon Feb 07, 2011 8:04 am

Re: Bug in the new version 3.9.0.4072 64 bits

Postby BobGarrish » Sun Oct 20, 2013 5:13 am

Is it supposed to show the setup image (and only the setup image) during calbration? I used the generate images function to make a full set of calibration images on my hard drive, and they're all different, but when I try to scroll through them in the program (by right clicking on the projector screen), it always shows the same one when I click 'next pattern' all the way to 26.
BobGarrish
 
Posts: 8
Joined: Mon Feb 07, 2011 8:04 am

Re: Bug in the new version 3.9.0.4072 64 bits

Postby Bongobat » Sun Oct 20, 2013 5:14 am

Hi BobGarrish,

I think I saw elsewhere that you said were using a Macbook Air? I am no expert but I know David is designed and supported for a Windows PC and maybe their is some kind of issues with that unsupported configuration. Have you tried it on a regular PC with the same camera and projector? Has it worked before on that machine?

Greg
DealExtreme red line laser, Microsoft Lifecam HD-5000
User avatar
Bongobat
Moderator
 
Posts: 1002
Joined: Mon Apr 02, 2007 10:02 am
Location: Ohio, USA

Re: Bug in the new version 3.9.0.4072 64 bits

Postby BobGarrish » Sun Oct 20, 2013 5:19 am

BobGarrish
 
Posts: 8
Joined: Mon Feb 07, 2011 8:04 am

Re: Bug in the new version 3.9.0.4072 64 bits

Postby Bongobat » Sun Oct 20, 2013 5:44 am

Was thinking there may be a problem in the BIOS to open firmware translation in that kind of setup. Not sure how it handles the I/O on the hardware level. Was just a thought :oops: Sven will get to you soon though I am sure.

Greg
DealExtreme red line laser, Microsoft Lifecam HD-5000
User avatar
Bongobat
Moderator
 
Posts: 1002
Joined: Mon Apr 02, 2007 10:02 am
Location: Ohio, USA

Re: Bug in the new version 3.9.0.4072 64 bits

Postby BobGarrish » Sun Oct 20, 2013 5:56 am

BobGarrish
 
Posts: 8
Joined: Mon Feb 07, 2011 8:04 am

Re: Bug in the new version 3.9.0.4072 64 bits

Postby Sven » Mon Oct 21, 2013 11:36 am

User avatar
Sven
DAVID Developer
 
Posts: 1541
Joined: Mon Jan 22, 2007 8:59 am
Location: Braunschweig, Germany

Re: Bug in the new version 3.9.0.4072 64 bits

Postby MagWeb » Mon Oct 21, 2013 1:52 pm

@BobGarrish:

please give some further information about Windows on your MacBook Air (Specs? OSX version? Updated Bootcamp?). Maybe it's a GPU/chipset driver issue?

I remember some problems I had on a Leopard/Bootcamp installations some years ago concerning a second monitor. I could solve it by installing a "real" Windows driver package (in my case AMD Catalyst) from the WIN partion instead of using the GPU drivers provided by Apple's bootcamp.

Bootcamped Win7/DAVID 3.9 runs like a charm on my IMAC (OSX 10.8.5 ).
MagWeb
Moderator
 
Posts: 2499
Joined: Wed Jul 18, 2007 8:48 pm

Re: Bug in the new version 3.9.0.4072 64 bits

Postby Sven » Wed Oct 23, 2013 1:55 pm

To all who have the problem that the 64-bit version of DAVID 3.9.0 does not even start:
It seems we have found the problem. However we need you to test, because the problem does not occur on any of our own computers...

Please test this version and let me know if the problem is solved or not. If not, please post the error message!
:!: http://downloads.david-3d.com/software/ ... 0.4090.zip :!:

Thank you!

Sven
User avatar
Sven
DAVID Developer
 
Posts: 1541
Joined: Mon Jan 22, 2007 8:59 am
Location: Braunschweig, Germany

Re: Bug in the new version 3.9.0.4072 64 bits

Postby VDX » Sun Oct 27, 2013 11:11 pm

Hi Sven,

my problem seems to be the same as stated with the impossibility to install .Net 4.5 on this PC.

Viktor
Attachments
Fehlermeldung.jpg
VDX
 
Posts: 260
Joined: Wed Jul 04, 2012 1:35 pm

Re: Bug in the new version 3.9.0.4072 64 bits

Postby BobGarrish » Sun Oct 27, 2013 11:21 pm

I haven't had time to mess with it on the laptop again, but I can confirm that the SLS-1 hardware works on my desktop computer so the bug is specific to this computer.

I'll try again with the new version, and then mess around with driver changes and whatnot to see if they make a difference. Hard to see how the code to project one pattern would work but then get stuck on that pattern, but maybe finding out what fixes it on my machine will help you fix the program.
BobGarrish
 
Posts: 8
Joined: Mon Feb 07, 2011 8:04 am

Re: Bug in the new version 3.9.0.4072 64 bits

Postby Sven » Mon Oct 28, 2013 8:57 am

@Viktor:
That's bad. Without .NET 4.5, DAVID 64-bit will not run. You will have to use DAVID 32-bit.

@Bob:
Please try: Can you change the "Projector Brightness" setting (top of DAVID window), it should immediately make the any projected patterns darker/brighter?
Can you change "Screen ID" so that the pattern is shown on your monitor? Can you then change Projector Brightness, and "scan" or "calibrate" with the whole pattern sequence? (You may have to make the DAVID window smaller or move it to the projector, so you can see the patterns.)

Sven
User avatar
Sven
DAVID Developer
 
Posts: 1541
Joined: Mon Jan 22, 2007 8:59 am
Location: Braunschweig, Germany

Previous

Return to Bug Report

Who is online

Users browsing this forum: No registered users and 1 guest

cron