Dear DAVID Community,

As you are probably aware, the entire DAVID company, team and product range has been integrated into HP Inc.
This forum is now read-only. Relevant content has been migrated to HP and merged into HP's Support Forums on November 1, 2016.

To start new discussions for 3D Scanning, please register and post your new topic at the HP Support Forums

DAVID 3.7.0 beta2: 64-bit!

Discussions about latest DAVID developments, beta versions...

Re: DAVID 3.7.0 beta2: 64-bit!

Postby lblovett » Mon Mar 04, 2013 9:26 pm

Hi there, hopefully someone can help me out.

I have been using the latest 3.7 beta, over the last week or so, with a canon t2i (550d); it has been working incredibly, and with the latest version, it calibrates very simply... it has been working amazingly.

Today I tried using a t4i (650d), and since I plugged it in (initially it would show up in the list of "camera devices", but now not at all), now the t2i is also not showing up in the camera devices, and also the camera is staying dark when it is turned on.

I was not using the "extrawebcam" softaware before, and after I had difficulties today, I tried it out, but it didn't help. Has anyone else used the t4i or 650d with david (I have searched for references to it in the forums, but see no definite answers)?

Is there a driver I might be missing? I have tried reinstalling the "canon eos utilities" bundle disk, without luck.
lblovett
 
Posts: 7
Joined: Tue Jan 29, 2013 6:15 pm

Re: DAVID 3.7.0 beta2: 64-bit!

Postby lblovett » Mon Mar 04, 2013 10:06 pm

Sorry for the double comment, I completely uninstalled the EOS utilities, and then reinstalled again, and then re-booted, and now the t2i is back in action; I would really like to be able to use the t4i (aka 650d) though, does anyone have existing advice on this, or could I propose adding drivers for it into the next update?
lblovett
 
Posts: 7
Joined: Tue Jan 29, 2013 6:15 pm

Re: DAVID 3.7.0 beta2: 64-bit!

Postby xoxu » Tue Mar 05, 2013 2:35 pm

I use a 600D without probleme with the 3.7beta2 x86
xoxu
 
Posts: 14
Joined: Thu Jan 10, 2013 10:59 am

Re: DAVID 3.7.0 beta2: 64-bit!

Postby dangre » Tue Mar 05, 2013 5:56 pm

xoxu wrote:I use a 600D without probleme with the 3.7beta2 x86


xoxu,
I have been looking at the 600D (T3I) and was wondering if you could give some details one how well it works with the latest David? Can you change camera settings in David? Are you using ExtraWebCam? Can you share some photos of your results? Thanks in advance, Dan
Dan
DAVID-CAM-1-C, Acer K11, Macro lenses for K11, Logitech Pro 9000, EOS 40D
User avatar
dangre
 
Posts: 61
Joined: Sun Jun 03, 2012 2:37 am
Location: SW Michigan, USA

Re: DAVID 3.7.0 beta2: 64-bit!

Postby xoxu » Wed Mar 06, 2013 9:58 am

Hello Dan

It work with latest David 3.7 beta2 but only with the 32bit version
I can't change setting or resolution in David and i didn't use extrawebcam
here can found a result with this configuration :
http://www.david-laserscanner.com/forum/viewtopic.php?f=10&t=5474
xoxu
 
Posts: 14
Joined: Thu Jan 10, 2013 10:59 am

Re: DAVID 3.7.0 beta2: 64-bit!

Postby dangre » Wed Mar 06, 2013 3:17 pm

xoxu,
If the propeller blade scan is what you are referring to, I am getting the same 'flickering' of the scan with my Canon 40D. When I scan a disk shaped object on my turntable these 'flickering' (waveforms) create a 'weave' pattern which greatly reduces the ability to align scans and give good results. My Pro9000 does not show this 'flickering' but the resolution is not as good as the 40D. I have a DAVID-CAM-1-C on the way but would love to try to get the Canon to work. I am using the latest 64-bit beta.
Attachments
Capture1.JPG
Dan
DAVID-CAM-1-C, Acer K11, Macro lenses for K11, Logitech Pro 9000, EOS 40D
User avatar
dangre
 
Posts: 61
Joined: Sun Jun 03, 2012 2:37 am
Location: SW Michigan, USA

Re: DAVID 3.7.0 beta2: 64-bit!

Postby xoxu » Mon Mar 11, 2013 6:21 pm

dangre,
the "flickering" is more visible when the focus isn't very good and when my object is above 30-40cm
can you use the canon with the 64bit software?
xoxu
 
Posts: 14
Joined: Thu Jan 10, 2013 10:59 am

Re: DAVID 3.7.0 beta2: 64-bit!

Postby Shorty » Mon Mar 11, 2013 10:57 pm

Hi All,
Cant seem to make the David3 X64 work with Ueye 1545 Le Camera.
All other functions work Ok,just dosnt reconize the Ui camera.
I.e Camera properties and camera format button cannot be sellected
and no live out

The Ueye works great with 32 bit Version 3.7.0.beta2 build 3556
Just not the X64. :cry:

Any thoughts????


Thanks
Shorty
Shorty
 
Posts: 20
Joined: Tue Feb 17, 2009 10:53 am

Re: DAVID 3.7.0 beta2: 64-bit!

Postby Simon » Wed Mar 13, 2013 12:56 pm

Shorty wrote:The Ueye works great with 32 bit Version 3.7.0.beta2 build 3556
Just not the X64.


I don't know the reason why your Ueye doesn't work with DAVID_64bit, but maybe you need other webcam drivers for x64 (if available)?
User avatar
Simon
DAVID Developer
 
Posts: 423
Joined: Sun Jan 21, 2007 3:40 pm
Location: Braunschweig - Germany

Re: DAVID 3.7.0 beta2: 64-bit!

Postby dangre » Wed Mar 13, 2013 4:21 pm

My Canon 40D is working with 3.7.0 Beta2 and it seems to be using the ExtraWebCam software. I think it is the way I have the camera set that gives less than optimum results (not fault of David). I will play with it in the future but for now my newly acquired DAVID-CAM-1-C is working so well that it may be awhile before I can try the 40D again! If you are wondering whether to buy the official David camera, it has completely changed the way I look at scanning now. Wow, the possibilities!

I get the dreaded 'blue screen of death' on one of my laptops when David try's to read the DAVID-CAM-1-C. Win7 Dell Precision M4400. The error states the driver has an incompatibility. I am using the drivers from my USB stick. Does anyone have any advice on other drivers I could use?
Dan
DAVID-CAM-1-C, Acer K11, Macro lenses for K11, Logitech Pro 9000, EOS 40D
User avatar
dangre
 
Posts: 61
Joined: Sun Jun 03, 2012 2:37 am
Location: SW Michigan, USA

Re: DAVID 3.7.0 beta2: 64-bit!

Postby k_thod » Wed Mar 13, 2013 4:29 pm

Hello,

Great to see that the final 3.7 is out ..good job !..i'll use it for the contest :)

Perhaps you can tell us a little more why Canon are not supported by the 64 bit version ? and if it'll be ?

Another thing, i don't have my Usb key here and i don't remember if there was something like that but do you have a full "release note" for this one since the 3.5 ?

regards,

K_thod
550D / Acer K11
User avatar
k_thod
 
Posts: 54
Joined: Thu Jan 19, 2012 7:23 pm

Re: DAVID 3.7.0 beta2: 64-bit!

Postby Shorty » Wed Mar 13, 2013 10:05 pm

Simon wrote:
Shorty wrote:The Ueye works great with 32 bit Version 3.7.0.beta2 build 3556
Just not the X64.


I don't know the reason why your Ueye doesn't work with DAVID_64bit, but maybe you need other webcam drivers for x64 (if available)?



Thanks Simon for the reply.
What would you suggest I try?
All the Ueye drivers are the latest and the computer is new.

Regards
Shorty
Shorty
 
Posts: 20
Joined: Tue Feb 17, 2009 10:53 am

Re: DAVID 3.7.0 beta2: 64-bit!

Postby k_thod » Wed Mar 13, 2013 10:14 pm

Hum still unable to edit my posts .
So , my apologies, the changelog show up after installation :oops: ..

Sorry
550D / Acer K11
User avatar
k_thod
 
Posts: 54
Joined: Thu Jan 19, 2012 7:23 pm

Re: DAVID 3.7.0 beta2: 64-bit!

Postby Shorty » Thu Mar 14, 2013 11:57 am

dangre wrote:.........." it has completely changed the way I look at scanning now. Wow, the possibilities!


I'm looking a buying anew camera and are still considering, the point grey looks good
But how did the david cam change the way you look at scanning?
And how long would a scan take on the high ,default,low settings with this cam.
I'm after one that has good resolution but fast for people scanning.
Any ideas

Thanks
Shorty
 
Posts: 20
Joined: Tue Feb 17, 2009 10:53 am

Re: DAVID 3.7.0 beta2: 64-bit!

Postby Simon » Thu Mar 14, 2013 12:08 pm

k_thod wrote:So , my apologies, the changelog show up after installation :oops: ..

No Problem.
The release history (i.e. changelog) can also be found here: http://www.david-laserscanner.com/wiki/david-release-history

k_thod wrote:Perhaps you can tell us a little more why Canon are not supported by the 64 bit version ? and if it'll be ?


The problem is that Canon only published 32-bit dlls along with their SDK (i.e. EDSDK). But there is hope: Recently, they offer a 64-bit version which is still in an early beta stage.
About the EDSDK 64-bit Library they wrote:

Limited to the camera connect functions, we released a 64-bit library as a beta
version on a trial basis.

Since we don't support functions to handle image file in the 64-bit library,
the EdsCreateImageRef will be an error.

Unfortunately, we need the "EdsCreateImageRef" function to transfere images from EOS to PC. So we must have patience and hope...
Alternativly we could develope an extra 32-bit application which communicates with the EOS and transfers the images to DAVID_x64. But this would be a lot of work.
User avatar
Simon
DAVID Developer
 
Posts: 423
Joined: Sun Jan 21, 2007 3:40 pm
Location: Braunschweig - Germany

PreviousNext

Return to DAVID Development

Who is online

Users browsing this forum: No registered users and 1 guest

cron