Dear DAVID Community,

As you are probably aware, the entire DAVID company, team and product range has been integrated into HP Inc.
This forum is now read-only. Relevant content has been migrated to HP and merged into HP's Support Forums on November 1, 2016.

To start new discussions for 3D Scanning, please register and post your new topic at the HP Support Forums

bad results

Problems, solutions and discussion about scanning with a video projector and stripe patterns.

bad results

Postby volume » Mon Sep 01, 2014 9:59 pm

I scanned my SLS1 many parts with very good results,
this is a piece of 3cm
Image
Image

but not the reason has started to deform the end of the scans, it is as if the parts of the right and left were as open towards the camera

Image

Because of this and thinking that the lens of the camera or the projector had suffered a distortion due to be working with high temperatures I decide to buy a SLS2 and get the same results even changing pc

Image

Image

Image
volume
 
Posts: 51
Joined: Wed Nov 18, 2009 9:35 pm

Re: bad results

Postby MagWeb » Tue Sep 02, 2014 12:24 am

hmmm,

I assume you calibrated on the corner shipping with the SLS2 as well as onto the calibration target of the SLS1...so the corner should not be the problem causing such distortions... that's strange.

Are the files CameraSetup.xml and ProjectorSetup.xml in David-laserscanner3/Settings updated/modified after a calibration or after closing DAVID?
(enabling AdvancedSettings/Service/ShowDebugConsole might help)
MagWeb
Moderator
 
Posts: 2499
Joined: Wed Jul 18, 2007 8:48 pm

Re: bad results

Postby volume » Tue Sep 02, 2014 9:56 am

And if I upgrade my usb will not return to their default values?


I do not recall changing any settings but not ruling anything ...
volume
 
Posts: 51
Joined: Wed Nov 18, 2009 9:35 pm

Re: bad results

Postby volume » Tue Sep 02, 2014 10:04 am

Image

Image
volume
 
Posts: 51
Joined: Wed Nov 18, 2009 9:35 pm

Re: bad results

Postby milz » Tue Sep 02, 2014 10:30 am

heho

on the second picture from the bottom i see wavy scans.
waves a often causes in bad fusion result. maybe you can trcik a little bit
try to combine the scans after align and the align the next to the group.
problems like this mostly happen when your corner are not perfect 90°
or you have to much bad infos in the scan like waves.
try to get scans without waves first is my suggestion. -)
nosie redution in the advanceed options and play with the quality check is also an option
to get better results...


mfg milz
Xeon x5650@4ghz
Cam : USB2 CCD 1024x768 / USB3 1280x900
Laser : LC532-5-3-F(16x65) Focusable Green
Projector Acer X110P / Acer K132
dControl one David control box + Turntable + automatic texture lights
mooooom bathroom!!!!!!
User avatar
milz
 
Posts: 520
Joined: Wed Jul 15, 2009 12:24 pm
Location: Germany Cologne

Re: bad results

Postby volume » Tue Sep 02, 2014 2:00 pm

sorry
Image

Image

Hi milz, the calibration panel is perfect, is the panel of David SLS2
volume
 
Posts: 51
Joined: Wed Nov 18, 2009 9:35 pm

Re: bad results

Postby milz » Tue Sep 02, 2014 2:42 pm

another way is to split the scans.
at the full size images the wave looks not so bad.
if you have an object with some deep its better to clean out the deep part or split it in two scans
and align it seperatly.
another trick for objects with a small / sharp corner like an coin
use stands with marks on it.
krabbenschere_coating.jpg


mfg milz
Xeon x5650@4ghz
Cam : USB2 CCD 1024x768 / USB3 1280x900
Laser : LC532-5-3-F(16x65) Focusable Green
Projector Acer X110P / Acer K132
dControl one David control box + Turntable + automatic texture lights
mooooom bathroom!!!!!!
User avatar
milz
 
Posts: 520
Joined: Wed Jul 15, 2009 12:24 pm
Location: Germany Cologne

Re: bad results

Postby volume » Thu Sep 04, 2014 6:48 am

MagWeb wrote:hmmm,

I assume you calibrated on the corner shipping with the SLS2 as well as onto the calibration target of the SLS1...so the corner should not be the problem causing such distortions... that's strange.

Are the files CameraSetup.xml and ProjectorSetup.xml in David-laserscanner3/Settings updated/modified after a calibration or after closing DAVID?
(enabling AdvancedSettings/Service/ShowDebugConsole might help)


Hi MagWeb, as I can return this files to their originalal state?, if damaged
volume
 
Posts: 51
Joined: Wed Nov 18, 2009 9:35 pm

Re: bad results

Postby MagWeb » Thu Sep 04, 2014 9:00 am

I suggest to keep all your setting files for debugging.

To get a completely fresh DAVID:
Create a independent installation instead. Download DAVID manually: http://www.david-3d.com/?section=Downloads
Run the installer choosing "extraction only" and extract to some location on your HDD ( DAVID should find the license on your USB also running the .exe from this location)

Another thing: Make sure that you've switched off keystone correction in your projector's menue.
MagWeb
Moderator
 
Posts: 2499
Joined: Wed Jul 18, 2007 8:48 pm

Re: bad results

Postby volume » Fri Sep 05, 2014 7:56 pm

MagWeb thanks for your advice, it worked almost well, there are still some places where these displacements occur between scanning and scanning
volume
 
Posts: 51
Joined: Wed Nov 18, 2009 9:35 pm


Return to Structured Light Scanning

Who is online

Users browsing this forum: No registered users and 2 guests