Dear DAVID Community,

As you are probably aware, the entire DAVID company, team and product range has been integrated into HP Inc.
This forum is now read-only. Relevant content has been migrated to HP and merged into HP's Support Forums on November 1, 2016.

To start new discussions for 3D Scanning, please register and post your new topic at the HP Support Forums

Calibration not getting saved

The place for questions, problems, comments and tips regarding the camera calibration.

Calibration not getting saved

Postby benoy » Sat Aug 16, 2014 3:55 am

Hi Hello,
I am a happy David user. With tons of perfect scans in the past 3 year.

But recently I am facing a problem. The shape fusion was not giving me satisfactory result. So I re-calibrated David and then it was fine. But the next time I open David again Shape fusion is not satisfactory. I Re-calibrate it then it is fine. So now each time I use David I have to re-calibrate and use.
Camera and projector are fixed could there be any setting or any other that I have missed out?
Regards
and Best to the Team

Benoy
benoy
 
Posts: 143
Joined: Wed Feb 11, 2009 8:03 pm
Location: India

Re: Calibration not getting saved

Postby hunkatibor2 » Sat Aug 16, 2014 9:59 am

Hi Benoy
Interestingly, I also experienced this. I thought Nall is a problem.
Tibor
Intel Xeon E5410 2.33GHZ 16GB RAM Windows 7 64bit David 4.5.0
2 Basler A622F camera 2 Tamron Asfirical AF 28-80mm lense
LG DLP Projector PF1500G Canon D40 Tokina 17-70mm 1:2.8-4,5
Humanti Calibration panel system and Alignmed&Two camera
hunkatibor2
 
Posts: 1408
Joined: Tue Mar 16, 2010 4:26 pm
Location: Hungary

Re: Calibration not getting saved

Postby MagWeb » Sat Aug 16, 2014 10:37 am

benoy wrote:The shape fusion was not giving me satisfactory result.


What exactly is wrong in the fusion result?
Is it the color (white-) balance of the texture?
If yes, you might still run DAVID 10.2 or lower - update to current version which is 10.4
MagWeb
Moderator
 
Posts: 2499
Joined: Wed Jul 18, 2007 8:48 pm

Re: Calibration not getting saved

Postby benoy » Sat Aug 16, 2014 12:07 pm

Hello MagWeb,

By Shapefusion not working working I mean the automatic Alignment of the different scans works but the orientation is not perfect. There is a mal alignment of the different scans. But in the same setting if I re-calibrate it works well.

Thanks

Benoy
benoy
 
Posts: 143
Joined: Wed Feb 11, 2009 8:03 pm
Location: India

Re: Calibration not getting saved

Postby MagWeb » Sat Aug 16, 2014 5:02 pm

Hi benoy,

does this happen with files scanned in the previous, last session or scanned in a current session (without a fresh calibration)?

Just some questions to understand the problem - maybe you could try this?:
-Do a fresh calibration after a new start AND you do some scans with this calibration.
-Now please save these files without any alignment to a directory(A).
-Please align the files now (without closing DAVID)
-Save all files in their new position to a different directory(B).
-Close DAVID and restart it.
-Load the files with native orientation from directory A. Align them the very same way and the same order as you did it before.
-Now add the files from directory B.
>>> Is there some bigger difference (there might be some smaller difference due to the arbirtary auto-align start)? If yes, we should investigate this....

If these sets A and B match quite the same way, I assume you mean that meshes scanned after a new start using the calibration of a previous session don't match?
Are the files CameraSetup.xml and ProjectorSetup.xml (in the Settings directory) updated after you close DAVID? (to make that sure, you might rename the old xmls - DAVID should write new files) If yes:
Maybe the problem is due to different working temperatures of cam and projector (calibrate and scan only after some warm-up time of both devices)? - This would mean that there should be also a problem if you calibrate your system being cold, wait some minutes and scan after that pause....

BTW: Which DAVID version do you use?
MagWeb
Moderator
 
Posts: 2499
Joined: Wed Jul 18, 2007 8:48 pm

Re: Calibration not getting saved

Postby hunkatibor2 » Sat Aug 16, 2014 6:20 pm

Hi
Try to reproduce the phenomenon.
Calibration - save-examination.
Exit.
Loading David.
Loading 01.OBJ
Examination -automatic alignment.
The results do not overlap are examined.
Re-examination, automatic alignment, do not overlap
Tibor
Attachments
2014-08-16_19-10-57.png
the first blue
Intel Xeon E5410 2.33GHZ 16GB RAM Windows 7 64bit David 4.5.0
2 Basler A622F camera 2 Tamron Asfirical AF 28-80mm lense
LG DLP Projector PF1500G Canon D40 Tokina 17-70mm 1:2.8-4,5
Humanti Calibration panel system and Alignmed&Two camera
hunkatibor2
 
Posts: 1408
Joined: Tue Mar 16, 2010 4:26 pm
Location: Hungary

Re: Calibration not getting saved

Postby Sven » Sun Aug 17, 2014 4:07 pm

Hi Benoy,

It would be interesting to see if there any problems writing or reading the configuration files (subfolder "Settings", files "CameraSetup.xml" and "ProjectorSetup.xml").
Please check (as Gunter suggested) whether the files are updated each time you calibrate and each time you close DAVID (they should get a new time stamp).
Also please look at the Debug Console Window during start and when closing. It should not show any error messages.

Sven
User avatar
Sven
DAVID Developer
 
Posts: 1541
Joined: Mon Jan 22, 2007 8:59 am
Location: Braunschweig, Germany

Re: Calibration not getting saved

Postby milz » Tue Aug 19, 2014 6:59 pm

Heho

Simple way -)
To prepare lost of calibration cause David crash (it should happens from time to time)
i allways save the calibration xml´s by click the save button ...
If you use the USB Stick Version check if it´s not out of memory -)

mfg milz
Xeon x5650@4ghz
Cam : USB2 CCD 1024x768 / USB3 1280x900
Laser : LC532-5-3-F(16x65) Focusable Green
Projector Acer X110P / Acer K132
dControl one David control box + Turntable + automatic texture lights
mooooom bathroom!!!!!!
User avatar
milz
 
Posts: 520
Joined: Wed Jul 15, 2009 12:24 pm
Location: Germany Cologne

Re: Calibration not getting saved

Postby Sven » Tue Aug 26, 2014 3:57 pm

Hi Milz,
DAVID does indeed save the calibration result to "Settings" sub-folder immediately after calibration, so you wouldn't lose it in case DAVID crashes (which of course it never does ;-)
Sven
User avatar
Sven
DAVID Developer
 
Posts: 1541
Joined: Mon Jan 22, 2007 8:59 am
Location: Braunschweig, Germany

Re: Calibration not getting saved

Postby milz » Sun Aug 31, 2014 8:37 am

moinmoin

ah ok. i do this since David2. Most probs with crash and lost calibration are gone with David3 btw 64bit.
David3 is a great and stable product. or let say with the word out of satillete receiver manual.
"Ihr Receiver verhält sich wie Ihr PC. Von Zeit zu Zeit kann er abstürzen." sry cant translate this... :P
If you said it´s saved automaticlly i had the same prob. Would it saved again at close ?
i see the message in the debug window.
Sven wrote:Hi Milz,
DAVID does indeed save the calibration result to "Settings" sub-folder immediately after calibration, so you wouldn't lose it in case DAVID crashes (which of course it never does ;-)
Sven
Xeon x5650@4ghz
Cam : USB2 CCD 1024x768 / USB3 1280x900
Laser : LC532-5-3-F(16x65) Focusable Green
Projector Acer X110P / Acer K132
dControl one David control box + Turntable + automatic texture lights
mooooom bathroom!!!!!!
User avatar
milz
 
Posts: 520
Joined: Wed Jul 15, 2009 12:24 pm
Location: Germany Cologne

Re: Calibration not getting saved

Postby Sven » Mon Sep 01, 2014 5:42 pm

Hi milz,
You are right, DAVID saves the calibration again when you close it. That's not really necessary any more... :wink:
It saves ALL settings on exit.
Sven
User avatar
Sven
DAVID Developer
 
Posts: 1541
Joined: Mon Jan 22, 2007 8:59 am
Location: Braunschweig, Germany


Return to Camera Calibration

Who is online

Users browsing this forum: No registered users and 2 guests