Dear DAVID Community,

As you are probably aware, the entire DAVID company, team and product range has been integrated into HP Inc.
This forum is now read-only. Relevant content has been migrated to HP and merged into HP's Support Forums on November 1, 2016.

To start new discussions for 3D Scanning, please register and post your new topic at the HP Support Forums

Camera and projector calibration problems

The place for questions, problems, comments and tips regarding the camera calibration.

Camera and projector calibration problems

Postby Azun » Thu Oct 03, 2013 1:30 pm

Greetings to all forum members.
At the beginning sorry for my English.

Well I must say that David is my first contact with 3D scanning (earlier read about it). I would like to make SL scanning.
My equipment (borrowed from friends) is
camera: IDS uEye UI-1550LE-C-HQ with 16mm 1:1,4 lenses.
Projector:
a) Casio XJ-A241
b) Optoma PK301

I was trying to make positive and negative corners with better or worse accuracy.
I had best effects with negative corner. But after making camera calibration my both projectors failed with their calibration. When I was trying to put projector closer or further without moving my camera everything went bad. And I couldn't be able to find a perfect position, or even get back to earlier "working" position. Also I am using 3.8.1 version. New 3.9 doesn't support my camera.

Now I'm trying positive A4 corner with 161mm scale but I can't find a good distance to pass camera calibration.

I tried several measurements on one position (camera,projector and corner without moving), and RMS value was jumping from 5.2 to even 220... and sometimes it just passed with RMS below 5.

Right now I can't send pictures of my set up. I don't have any tripods or anything like that. Corner, camera and projector ale on the floor.

I even tried setting camera and projector according to David wiki. But also unsuccessful.

I hope Someone will suggest anything.
With best wishes
Azun

ps. I saw that screenshot was made with red line little cut on blue line. Other trials were made with better precaution.
Attachments
Bez tytułu53.jpg
My best try with negative corner
Azun
 
Posts: 2
Joined: Tue Oct 01, 2013 1:11 pm
Location: Poland

Re: Camera and projector calibration problems

Postby WalterMo » Thu Oct 03, 2013 6:57 pm

Hi Azun,

I can see two bad things on your screen shot:
1. On the right wall of the calibration corner: The black ring with my red arrow must not be there. It must be where my white ring is. You have interchanged both calibration sheets. Therefore DAVID cannot calibrate! Look here:
http://wiki.david-3d.com/david3_user_ma ... alibration

2. On the left wall of the corner the camera (and DAVID) 'sees' more than the wall, means a background. Put the camera closer to the corner so that it only 'sees' the calibration sheets! Of all the dots and rings it must minimal only 'see' the six rings.

Walter

PS. Adjust the camera settings in such a manner that the red sinusoidal waves are symmetrical to the dotted line and its amplitude is as big as possible but not flat (overdriven) at the maximum and minimum (at the blue lines). The amplitude of your waves is ok, only adjust them more symmetrically.
Attachments
Azun2.jpg
User avatar
WalterMo
Moderator
 
Posts: 2363
Joined: Mon Apr 02, 2007 6:52 pm
Location: Braunschweig, Germany

Re: Camera and projector calibration problems

Postby Azun » Tue Oct 08, 2013 10:45 am

Thank You Walter for Your help.
It worked wery vell. Even in first try!
I was trying earlier 3 days to calibrate and I didn't realised that my camera switched dots position on calibration panel.
Once again many thanks.
With best whishes
Azun :)
Azun
 
Posts: 2
Joined: Tue Oct 01, 2013 1:11 pm
Location: Poland


Return to Camera Calibration

Who is online

Users browsing this forum: No registered users and 2 guests

cron